SharePointCommunity
Die deutschsprachige Community für SharePoint, Office 365 und mit Azure

Sharepoint VM defekt - Content DB wieder integrieren

bewertet von 0 Usern
Beantwortet Dieser Beitrag hat 1 Geprüfte Antwort | 13 Antworten | 1 Follower

Top-500-Beitragsschreiber
30 Beiträge
bigfoot erstellt in 5 Nov 2014 15:59

Hallo zusammen,

wir haben unseren SharePoint 2007 vor ca. 1 Jahr abgeschaltet, jetzt wurde aber festgestellt, dass noch Daten davon benötigt werden. Leider ist die Hyper-V Umgebung in der Zwischenzeit aktualisiert worden und die SharePoint Maschine hat das Update nicht vertragen. Nachdem die Content Datenbanken auf einem eigenen SQL Server liegen, dachte ich es ist einfacher eine neue VM hochzuziehen und die Content Datenbanken zu integrieren.

Also habe ich eine VM mit Sharepoint 2007 SP3 installiert, neue WebApplication auf Port 30000 eingerichtet, dann die alte Contentdatenbank mit AddContentDB dauzugehängt und mit MergeContentDB zusammengeführt.

Jetzt habe ich auf der :30000 zwar die leere neue WebApplication, weiß aber nicht wie ich an die weiteren Daten komme.

Ich weiß noch, das es damals eigene TeamSites waren und ich habe auch noch einen Link davon im Outlook gefunden, aber ich weiß nicht wir im Neuen aufrufen.

 

Im Alten Sharepoint hieß der Link

https://SharepointURL/Intern

im neuen heißt die webApplication

http://SharepointNeuURL:30000/sites/webAppName/default.aspx

jetzt hätte eigentlich erwartet unter

http://SharepointNeuURL:30000/sites/Intern

die alten Daten zu bekommen, aber leider bekomme ich einen IE 500 Fehler.

http://SharepointNeuURL:30000/sites/webAppName/Intern (404 Fehler)

http://SharepointNeuURL/Intern (404 Fehler)

Kann mich da bitte jemand anleiten, wie ich schnellstmöglich an die Links bzw. Daten komme?

 

Danke

Beantwortet Geprüfte Antwort

Top-500-Beitragsschreiber
30 Beiträge

So, from scratch – Ausgang war ein SharePoint der den Umzug seiner Hyper-V Maschine nicht überstanden hat.

Warum – keine Ahnung.
Sicherung – bringt nix – Hyper-V muss ja trotzdem aktualisiert werden.
Lösungsansatz – neue Hyper-V aufsetzten, SharePoint installieren und ContentDB vom alten drunter hängen.

Erfolgloser Versuch:
OS Server 2008 R2 EN, SharePoint 2007 SP 3 EN, SQL 2012 EN

Es kamen immer wieder komische Fehler die auf Spracheinstellungen hindeuten.

Failed to open the language resource keyfile core. 
Cannot open "core.de-DE.resx": no such file or folder.

Sprachpaket installieren hat nix gebracht!
Kopieren von .resx wie in Google teilweise beschrieben, bringt auch nix.

Lösung:

OS Server 2008 EN, SharePoint 2007 ohne SP, SQL 2012 EN

SharePoint 2007 installieren und eine WebApplikation anlegen.
Dann ContentDB davon mit STSADM oder über GUI trennen.

stsadm -o deletecontentdb -databasename content_DB -url http://spsite

Heißt zwar delete – löscht aber nichts, sondern entfernt nur die Verknüpfung zwischen SharePoint und DB im SQL Server.

Danach – Rücksicherung der alten ContentDB wieder auf SQL Server einspielen und dann mit

stsadm -o addcontentdb -url http://spsite -databasename content_db

versucht hinzuzufügen.

Dann habe ich eine Fehler bekommen – die Version des installieren SharePoint’s entspricht nicht dem der Datenbank. Also SP1 installiert und noch mal versucht – gleicher Fehler – also SP2 installiert und tada!

Kein Fehler, keine Probleme, alles wunderbar, hoffe es hilft jemand.

 

Anmerkung:
SharePoint 2007 geht nur mit Server 2008 R2, wenn schon mit SP3 installiert wird.
Bit Versionen beachten, unter 2007 gab es noch 32 Bit SharePoint

Alle Antworten

Top-10-Beitragsschreiber
18.805 Beiträge

bigfoot:
http://SharepointNeuURL:30000/sites/Intern

die alten Daten zu bekommen, aber leider bekomme ich einen IE 500 Fehler

Das klingt am interessantesten, weil es dort zumindest etwas gibt. 500 heißt interner Serverfehler und man sollte in den Logs mehr dazu finden. Was sagt denn der View all site collections Link in der Zentraladministration?

Eine ganz andere Möglichkeit wäre auch einen SharePoint 2010 aufzubauen und die Datenbanken dort einzuhängen.

Viele Grüße
Andi
af @ evocom de
Blog
Top-500-Beitragsschreiber
30 Beiträge

Danke für die Antwort.

SharePoint 2010 - würde ich, aber die alten DB haben noch MOSS 2007 ohne SP :/ > geht also nicht.

Und der Link - kannst du mir sagen wo der genau liegt ich finde den nicht :/

Top-500-Beitragsschreiber
30 Beiträge
Top-500-Beitragsschreiber
30 Beiträge

und die bringen alle 500

Top-10-Beitragsschreiber
18.805 Beiträge

Dann sind wir wieder bei meine ersten Rat: durchsuche die Logs nach der Fehlerursache. 500er werden dort normalerweise protokolliert.

Viele Grüße
Andi
af @ evocom de
Blog
Top-500-Beitragsschreiber
30 Beiträge

Gute Idee!

Failed to open the language resource keyfile core. 
Cannot open "core.de-DE.resx": no such file or folder.

Scheint wohl alt ein DE SharePoint gewesen zu sein. glaubst du Sprach Pack reicht da? Oder muss ich einen deutschen SharePoint installieren?

Top-10-Beitragsschreiber
18.805 Beiträge

Das deutsche Sprachpaket sollte reichen - zumindest ist es einen Versuch wert :-)

Viele Grüße
Andi
af @ evocom de
Blog
Top-500-Beitragsschreiber
30 Beiträge

so, Fehler in de-DE mit Sprachpaket weg, aber...

kannst du damit was anfangen?

Immer noch Fehler 500

Top-10-Beitragsschreiber
18.805 Beiträge

Die Meldung deutet darauf hin, daß auf dem alten System auch der Project Server installiert war. Den mußt Du jetzt wohl auch noch installieren (und dann nochmal das deutsche Server-Sprachpaket). Und evtl. Service Packs nachziehen.

Viele Grüße
Andi
af @ evocom de
Blog
Top-500-Beitragsschreiber
30 Beiträge

Hmm, kann ich machen, aber eigentlich - klares nein - der war da nicht installiert.
Aber ich installier den mal im Laufe des Tages...

So was wie einen "Abgesicherten SahrePoint Mode" gibt es nicht?
Ich brauch ja bloß 2 Std. Zugriff auf die Dokumente. :/

Top-10-Beitragsschreiber
18.805 Beiträge

Ich kann hier leider auch nur versuchen irgendwas in die Fehlermeldung hineinzuinterpretieren. Und er meckert eine fehlende Datei an, deren Adresse auf Project Server hindeutet. Mehr kann ich leider auch nicht sagen und ich wüßte auch keine andere Möglichkeit...

Viele Grüße
Andi
af @ evocom de
Blog
Top-500-Beitragsschreiber
30 Beiträge

So, from scratch – Ausgang war ein SharePoint der den Umzug seiner Hyper-V Maschine nicht überstanden hat.

Warum – keine Ahnung.
Sicherung – bringt nix – Hyper-V muss ja trotzdem aktualisiert werden.
Lösungsansatz – neue Hyper-V aufsetzten, SharePoint installieren und ContentDB vom alten drunter hängen.

Erfolgloser Versuch:
OS Server 2008 R2 EN, SharePoint 2007 SP 3 EN, SQL 2012 EN

Es kamen immer wieder komische Fehler die auf Spracheinstellungen hindeuten.

Failed to open the language resource keyfile core. 
Cannot open "core.de-DE.resx": no such file or folder.

Sprachpaket installieren hat nix gebracht!
Kopieren von .resx wie in Google teilweise beschrieben, bringt auch nix.

Lösung:

OS Server 2008 EN, SharePoint 2007 ohne SP, SQL 2012 EN

SharePoint 2007 installieren und eine WebApplikation anlegen.
Dann ContentDB davon mit STSADM oder über GUI trennen.

stsadm -o deletecontentdb -databasename content_DB -url http://spsite

Heißt zwar delete – löscht aber nichts, sondern entfernt nur die Verknüpfung zwischen SharePoint und DB im SQL Server.

Danach – Rücksicherung der alten ContentDB wieder auf SQL Server einspielen und dann mit

stsadm -o addcontentdb -url http://spsite -databasename content_db

versucht hinzuzufügen.

Dann habe ich eine Fehler bekommen – die Version des installieren SharePoint’s entspricht nicht dem der Datenbank. Also SP1 installiert und noch mal versucht – gleicher Fehler – also SP2 installiert und tada!

Kein Fehler, keine Probleme, alles wunderbar, hoffe es hilft jemand.

 

Anmerkung:
SharePoint 2007 geht nur mit Server 2008 R2, wenn schon mit SP3 installiert wird.
Bit Versionen beachten, unter 2007 gab es noch 32 Bit SharePoint

Top-500-Beitragsschreiber
30 Beiträge

Nachtrag:

Danke Andi für die Hilfe.

Seite 1 von 1 (14 Elemente) | RSS